Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: Release 13 (2.0.0.3)
    • Fix Version/s: Release 14 (2.0.0.7)

      Description

      Hey, seems scrolling doesn't work when the program is in 'partial app mode'. Tested on two computers.

      This should be a high priority issue, as it prevents me from purchasing after having tried it. Also scrolling doesn't work.

      Computer one: uTorrent client to the left (small), desktop (large) to the right. 2560x1440. Madcatz MMO7 (which I wouldn't be surprised if it uses some sort of hacky scrolling). I use the application AlwaysScrollWheel, which changes sends scroll commands to the window your cursor is hovering over rather than the window that has focus (seems to work on Metro just the same as legacy). Having the two applications swapped makes no difference. Microsoft Email application does not have this problem.

      Computer two: uTorrent client to the left (small), email to the right, desktop on second monitor fullscreen. 1920x1080 x2. Roccat Kone. Does not use AlwaysScrollWheel. Same issue, however, here the MS provided email application only accepts scroll once it receives focus with a click (as is to be expected.)

        Activity

        scidonem Michael added a comment -

        I can't reproduce this issue - scrolling works fine (granted, it doesn't until you click to give the app focus). Tested on 3 machines and on a Surface RT.

        Anonymous added a comment -

        I'd be willing to give any diagnostic information required.

        scidonem Michael added a comment -

        Even though according to your tests, computer #2 didn't use AlwaysScrollWheel, I'm going to install it on my dev machine and see what happens... Stay tuned

        scidonem Michael added a comment -

        Programs that forward scroll messages to the window under the mouse cursor fail with Windows Store XAML apps.

        You can reproduce this issue with any Windows Store XAML application.

        Apps like Mail work because they are JavaScript apps rendered inside Internet Explorer.


          People

          • Assignee:
            scidonem Michael
            Reporter:
            Anonymous
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: